Debug message: can't find "general/mod.slb"

General discussion about Outpost Kaloki for personal computers

Moderators: Marmosetofdeath, ninjabees

mgfa6mmt2r
Posts: 2
Joined: Sun Mar 23, 2008 12:07 am

Debug message: can't find "general/mod.slb"

Postby mgfa6mmt2r » Tue Jul 08, 2008 5:21 am

I downloaded Outpost Kaloki's installer from the NinjaBee website. I ran the installation, and the only thing I changed was to rename the install path from "C:\Program Files\Outpost Kaloki" to "C:\Program Files\KalokiOutpost" (reversed the words, and removed the space between them).

When I ran the executable (C:\Program Files\KalokiOutpost\OutpostK.exe), I got the "this is a trial version... you have 57 minutes remaining...":
Image

I clicked "Continue" to start the trial, and after a few seconds of no activity, I get a popup that looks like this:
Image

This is followed by a crash message:
Image

Then I get another registration screen:
(I can't add it: 3 attachment max limit on this forum, but it basically shows the first reminder screen with extra info, like "The full version allows you to ..." as well as the time remaining for gameplay.)

It won't let me progress any further from here. Anyone else get this? Any ideas?
Attachments
error_application_error.png
Application error
error_application_error.png (10.8 KiB) Viewed 5898 times
error_reminder.png
Reminder of 57 minutes of gameplay remaining
error_reminder.png (100.44 KiB) Viewed 5892 times
error_debug.png
Snapshot of: Can't find file "general/mod.slb" in 1 paths
error_debug.png (6.33 KiB) Viewed 5916 times
User avatar
staticwrap
Posts: 1359
Joined: Thu Jul 27, 2006 5:19 am
Location: The OC NY
Contact:

Re: Debug message: can't find "general/mod.slb"

Postby staticwrap » Thu Jul 10, 2008 3:32 am

Well, I for one would have reinstalled the software. Seems like the simplest fix. If you really want to have your directory named like that, there is probably a technical answer for you by one of the developers. I know this really doesn't help, but I would really try to reinstall the software with the default settings. If you tried that already, sorry, but it does seem like the most obvious route.
Image
User avatar
stay
NinjaBee
Posts: 1790
Joined: Wed Sep 15, 2004 11:25 pm

Re: Debug message: can't find "general/mod.slb"

Postby stay » Fri Jul 11, 2008 11:55 pm

Hmm... Interesting. That message ("can't find...") means that the executable doesn't know where its data is. This sort of makes sense, since you renamed the folder where it got installed, though I'm still not sure why this error is coming up.

Are you renaming the folder *after* it's installed, or during the install process? I assume the latter.

I assume you're running the game from Start Menu -> All Programs -> Outpost Kaloki -> Outpost Kaloki

That last "Outpost Kaloki" with the green O icon is actually a shortcut. If you right-click on it instead of left-clicking, you can choose "properties" from the popup menu. In the "Outpost Kaloki Properties" window, there's a "Start in" line. That should match the new folder name you're using, where the actual executable is. In other words, it should say "C:\Program Files\KalokiOutpost".

Is there still an "fsall" folder inside the KalokiOutpost folder? You should have, in your KalokiOutpost folder, a folder called "fsall" and inside that "blockfiles" and inside that four files named things like "Full_Common.blk".

If those files exist and the executable can find them, it should run without that error.

I tried doing exactly what you did, and it seemed to work fine for me.

Could you also try running the executable directly by opening the KalokiOutpost folder and double-clicking on OutpostK.exe? Does that behave any better?

Finally, could you open the "log.txt" file that's in your KalokiOutpost folder and tell me the first few lines? They should look something like:

INIT FS
Current Directory is C:\Program Files\KalokiOutpost
POST INIT FS

Thanks,
-- stay
mgfa6mmt2r
Posts: 2
Joined: Sun Mar 23, 2008 12:07 am

Re: Debug message: can't find "general/mod.slb"

Postby mgfa6mmt2r » Tue Jan 20, 2009 3:22 am

I know this reply is horribly, horribly outdated, but I thought I'd post my findings.

I've been running my browser (IE 6) through a sandbox called Sandboxie. When I downloaded the game, it downloaded it under the sandbox as well. Installation was ALSO within the sandbox. I was unaware that the programs that I download through IE -- when running IE in this particular sandbox program -- would be bound to the sandbox as well. It's my own fault that I didn't notice that the window titles had those "[#] ... [#]" surrounding them, indicating that they were running within the sandbox.

I redownloaded the installer with a browser OUTSIDE of the sandbox, and installation worked fine. The game is awesome! Definitely something I recommend to my friends! Thanks for the help!

Return to “Outpost Kaloki (PC/Mac)”

Who is online

Users browsing this forum: No registered users and 1 guest